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Introduction (Downloading KompoZer)

KompoZer is a complete web authoring system that combines web file
management and easy-to-use WYSIWYG (What You See Is What You Get) web

page editing.

Step 1
Open your browser go browse to http://kompozer.net/ .

You should see something like Figure 1:

I @ |http:,|',l'kompozer.net,l' ﬁ -

KompoZer

Nvu's unofficial bug-fix release

----------------------------------------------------------------------------------------

. Easy web authoring

o

! KompoZer is a complete web authoring system au— :
© that combines weh file management and ,_r
r
12

KampoZer is designed to be extremely easy to — =
i use, making it ideal for non-technical computer !
i users who want to create an attractive,

. professional-locking web site without needing

¢ to know HTML or weh coding.

:
 Learn more. ..
;

You can keep an eye on KompoZer's development in the developer’s weblog.

If vou like KompoZer, please consider danating to support the development.

Figure 1: KompoZer Home Page

Click on the “Download!” button, which will bring you to the download page.



Step 2
Choose the program which suits your Operating System (OS). For example, If
you are using Microsoft Windows, choose kompozer-0.7.10-win32.zip. (NOTE:

Name of the file is correct as of the writing of this guide; 31 March 2009 and may
subject to change).

In this example we use the Windows OS.

KompolZer

Nvu's unofficial bug-fix release

Dowenload

Latest stable version: 0.7.10 (2007-08-30)

A¥wWinaz hinary
kompozer-0.7.10-win32.zip (7.6 MB) - compiled with YC++ 7.0 on Cygwin

EMacOS ¥ ppo hinary
kompozer-0.7.10-mac.dmg {11.0 MB} - contributed by Sébastien Desvignes {aka bobo)
successfully tested on both PPC and Intel based Macs
£3Linux 486 binary
kompozer-0.7.10-gcc4.0,.3-i486.tar.gz {10.3 MB) - built with gcc/g++ 4.0.3 on Linux 2.6.15
kompozer-0.7.10-i386.deb (8.2 MB) - successfully tested on Debian Etch and Ubuntu 6.06 to 7.10
kompozer-0.7.10-i286.rpm (8.2 MB) - successfully tested on RHELE, Fedara Core 4 to 7 and Mandriva 2007
Source code
tarball (33.7 MB) - built against Mwvu 1.0 source code (Mozilla awiary branch)

Figure 2: Kompozer Download page

Step 3



Once you have clicked the respective file according to your OS, the browser
should redirect you to another page where the download will be automatically
prompted. Save your file to an easily accessible location.

EBelat  Youhave chosen to open L
[¢ ] kompozer-0.7.10-win32.zip

which is a: ZIP file:
Frl:um http: ,l',l'nu:hu: dl.sourceforge. net

ST I R
€ gpenwin _rowse.. |
¢~ orbit Downloader
1+ i Save File

., Al Rights R d ; : : A
: b ™ Do this automatically For Files like this From naw on.

QK I Cancel

Figure 3: Save the file



Enter name of file to save to... j‘jﬂ

Save ir: IE_@‘ Desktop

i My Documents
E My Computer
My Mebwork Places
" Core FTP Like

I'WORLD SYCS
kompozer-0.7, 10-win32
kompozer user quide

bed 1 Doz

all Rights Re -

a“~
by Computer

S ShareFolder
R
<
Py M et File narme: .ﬂ
Pl:
Saw_a_a'é type: I j

Figure 4: Save to Desktop for easy access




Step 4
Once the download is complete, right click the downloaded file and click ‘Extract

All’ to your chosen location.

Open

Search.. .

Explore

Edit with Aptana Studio

Exkract all. ..
Scan selected Files with Ankivir

Backup

7-7ip
Cpen With

Send To

Cut
Copy

Create Shortouk
Delete
Rename

Properties

Figure 5: Extract the downloaded file



Step 5
You will be prompted with the following window. Click ‘Next’ until it finishes

extracting. (Refer to Figure 6 & 7).

Extraction Wizard j x|

Welcome to the
Compressed ( zipped)
Folders Extraction
Wizard

The extraction wizard helpz you copy fles
from inzide a ZIF archive.

To contife, click Mest.

< Back I MHest > I Cancel |

Figure 6: Click 'Next' until you see extract completed

Extraction Yizard x|

Extraction Complete —
Files have been successfully extracted from the ZIP archive.

Filez have been successiully extracted to the following
directony:

C:ADocumentz and Se.. \kompozer-0. 7.1 0-win321

To zee your extracted filez, check the box below:

W Show extracted files

Pressz finizh to continue,

< Back I Finizh I Cancel

Figure 7: Extract completed




Step 6
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"1 defaults.ini

Configuration Settings
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mangle.exe

nss3.dl
3.9.3.0
1SS Base Library

regchrome . exe

softokn3.dl
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Mozilla Foundation
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Jaukoreq
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nssckbi,dl
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NS5 Builkin Trusted Root Cas

regxpom, exe

ssl3.dll
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1SS 5501 Library

=[]
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Mozilla Foundation
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AccessibleMarshal.di
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jsazs0.di
4,0,0.0

msvcp70.dll
7.0,9064.0
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PLC Library

shiibsign.exe
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Figure 8: Double-click on the highlighter program

You should see somethin= similar to Fi= ure 9:
® untitled - KompoZer

Elle Edit Wew Insert Format Table Tools Help

greprefs

bloaturls, bt
Texk Document
1KE

Netscape 32-bit Javascript Ma..,

. kompozer.exe
* J Composer
& Mozilla Foundation

Microsaft (R} C++ Runtime Lib...

A= U

msver7o.dil
7.0.9064.0
Microsaft (R} © Runtime Library

plds4.dl
4.5.0.0
PLDS Library

smime3, di
3.9.53.0
M55 5/MIME Library

xpeom_compat. dil
0.0.0.0

xpt_dump.exe

# i
4 i
New Open  Save

G

b
Publish  Browes Undg Rado Anchor

Image Table  Form

- )

Cascades

I Paragraph j I

B = ZE

Variablewidh = |.|‘4?|A'}\“Bl Q|EE_;E

Figure 9: KompoZer Program

Now, you are ready to begin editing your websites. But before that, ensure you
have downloaded your websites from the FTP to your computer. Firstly, this is to

improve the efficiency of KompoZer. Secondly, this is to ensure your original

website on the FTP are available so that your visitors can still visit your website.

{unkitled) I %
~ Site Manager [ 3570x ]
Wiew: IAII Files: d
= PO =

Name: =
* tuarmal | 2 HTML Tags | 2] Source | ©-, preview
<body=



CoreFTP (Downloading Your Websites)

Step 1
Double-click on the CoreFTP.

Core FTP Lite

Figure 10: CoreFTP

Step 2
When the programs start, there will be a site manager screen. Alternatively, you

can select the button to bring up the site manager panel. You will be required to
fill in the following particulars for connection to the FTP server.

W

Figure 11: *Site Manager Button
« Site Name (This name of your website.)
*« HOST/IP/URL (The URL of your FTP server, which given to you.)

» Username (The given Username, which would the one used for entering
your Cpanel.)

* Password (The given Password, which would be the one used for
entering your Cpanel.)

The rest are recommended to be at default setting.



Site Manager

- @ W5 Site Mame

----- © Hubdbiz Imm.iwurldsvc:s.biz
L www iworldsves biz

Host /1P / URL

IHp.iwandsvcs.biz Advanced |

zermame

I- [ Anorymous
Pazzward

I v Don't save password
Fort Tirneout Fetries

|21 I E [~ Retry On

- 551 Options
™ &UTHSssL W S5L Listngs
[T AUTHTLS & S5l Transrers [ Comments

I~ 55LDiect I Clear [CCC)

[7 PasY [T SSHAFTR [ Use Prow

[T Openssl I windows 551

I e Sitel |NewEategnr_l,I| | Connect I !Eunnect M.‘:ﬂagell ‘ Cloze

Figure 12: Site Manager



Step 3

After successfully connecting, you should see something similar to Figure 13.

ore FTP LE - fip.fixnsystems.com:21

: =lolx
File Yiew Stes Manage Help

ne-|vee|BAED|% ¥ e

LisT :I

Connect socket #4976 10 74.53.162 84, port 32712
150 fevepted data connection

F36-Options: -a -|

i 37 matches total

CVD faccess-logs

CAVD

caivo 4

Transtemed 1,854 bytes in 0,018 seconds

Peix + [ o ok oo oo @ | 0415 X + T o e % v o0 @
i |C:ADocuments and Settings'ddministrator\Diesktophfiks' = < |/ =] M=
Filzname | Size | Date [ ;I "~ | Filenarme: | Size | Date | Permissions -
a css 03/31/09 11:M I: sqmaildata 02/13/09 0453 drseems
‘3 flash 03/31/09 11:M .: ACCEsslngs 0115709 0323 Inesnwrnae
23 images 0373109 1100 ) ete 02412/09 01:39  drwr-wrx
D img 03731409 11:M “3 mail 02/412/09 01:38  drosrse-
a ie 03/31/09 11:.01 a public_ftp 02412/09 0201 driamr-Er-g
u: portfolio 03431409 11:.01 I.: public_htrml 03/30/09 21:58  drur-we-
53 Scripts 03/31/09 11:M u: tmp 02/412/09 01:38  dresesrx
E working - M atalie 03/31/09 11:01 = 01A15/09 0310 Inasnasna
€] accessories. html JKB 02/19/09 1441 ‘bashic 124 01/15/09 0310
ié] chairs. html 3KB 0241309 1441 @ bash_logout 33 0415703 0310
] clients.html KB 02/19/09 1441 &) bash_profile 176 01415/09 0210
@] contact himl JKB 02419/09 1441 .contactemail 26 01/15/09 0311
L@] indes hitml 3KB 03/31/09 10:57 @ contactsavetime 10 01415709 0311
@] portfalio. htral 11KE 021909 1441 EMacs 515 01415/09 0310 -nwer-r- ||
|§] products.html 4 KB 02/13/09 1458 ftpguota 13 03/15/09 0201 T
) sys_fumiture html 10KE 02/19/09 1441 = gemic 149 01A5/09 0310 -twrrer
il= 4y i ~
Hast | Destination | Bytes Size | Rae | Type | Staus | Source |
Mo transfers,
vy == (11 bytes) ~ 0111509 05:10 | LI I I el P
Figure 13: FTP Display

The left display panel (the one enclose in green border as shown in Figure 13),

is the location of your files. You can choose where you want to save your
downloaded websites from the FTP.

The right display panel (the one enclose in red border as shown in Figure 13),

will display the folders on your FTP server.



Step 4
Locate the file ‘www’ on the right display panel and double-click on it.

) mazilla MA5039 0310 drwsr-sr-2
ﬂ.wskin mA15/09 0311 driar-r-x
3 - spamaszassin 03430409 2313 dows---
;ﬂ.sqmaildata 02413/03 0453 doesse--
.3 access-ogs MA509 023 Inwsnasnas
Cete 0212409 01:39  dowsr-sr-=
-.3 rail 02412409 01:32  dressr-s--
-.3 public_ftp 02M12/09 020 dritsr-r-x
a public_html 0373009 2158 doasr-s---
ﬂtmp 0242409 01:38 drvarsr-wr-x

WA 015409 0210 Ineesrausne
.bazhrc 124 015403 0310 =T
= bash_logout 33 MA509 0310 -nwer-r-
.bazh_profile 176 0A509 0310 -nwer--r-
.contactemai 26 0141509 02N Ti-nenee
.cohtactzavetinme 10 01A509 0311 rwer--r-
=" A A oHC An Ao e
Figure 14: 'www' folder on the FTP
Step 5

Once entered, select all the files in the ‘www’ folder except the ones (enclose in
red) as shown in Figure 15.

Al Filenanme | Size | [1ate | Permizzions |

015409 0210 dowvsr-sr-»
02/13/03 00:01 driasr-ar-»
02419409 01:08  dowvsr-sr-»
02419409 00:02  dowvsr-sr-x
0241309 0016 driassr-ar-»
02/19/09 0016 dowvsr-sr-»
029409 00:21 drr-Kr-x
0219/09 0024 driaasr-r-u
2KE 02/139/09 00:35  -pwer-r-
BEE 03/29/09 11:30 -pwer--r-
2KB 02/9/09 00:35  -nower--r-
JEE 02/139/09 00:35  -pwer-r-
FEE 02/13/09 00:35  -power-r-
r

3KB 02/19/09 0035 rwer-r-
KR 07909 0095 rsrer..

Figure 15: DO NOT SELECT THE FOLDERS IN RED



Step 6
Click the ‘Blue Left Arrow’ to begin downloading on to your computer.

SINGIE T ER- O e 4 o0 o0 @
b | I.-"www.-" LI rE:
Al Filerniame | Size | [rate | Permizzions | A||

Figure 16: Click this blue arrow to download the selected files

Now, you are ready to begin editing your websites using KompoZer.



KompoZer (Editing the Words)

Step 1
Open up the kompozer.exe. (Refer to Page 9 for instructions).

Step 2

Go to File > Open File and browse to the location where you downloaded the

FTP files.

SETE]

Fle Edt Wew Insert Format Tabls Tooks  Help

Mew Chrl+H -
- . @
Image  Tabl Form CaScades
Open web Location... Chrl+Shift+L =
Recent Pagss » - Himjiea)
Close T+
_ Close Al
I Save 45 {unititled) =
Save As I 87pr |
Save And Change Character Encoding
Publish Ckrl+Shift+5
Publish As.
Reert CHl+R

Reload Images

Expork to Text..

Browse Page Fs
Page Setup

Brint.. Chrl+P
Ezit Chrl+Q

Figure 17: File > Open File

Step 3
Select the page which you want to edit, in this example we use index.html which
is the home page of the website.

21|
Look in: Il'f} fii j e

| Tcss @ sws_Furniture, kil
| iflash

Bimages

|imag

ICis

| portFolio
@Scripts
\"Jworking - Matalie
i:lﬂ accessaries.hkml
Eij chairs. htril

@ clients.hkml

[i:] conkact, htril

indes, html
@purtﬁ:liu.html
@ products, bkl

File name: Iindex.html j
Files of type: |HTML Files =] Cancel |

Figure 18: Select a page to edit




Step 4
Now, you should be able to see the index.html displaying on KompoZer.

Fixx Systems [file:/.../portfolio.html] - KompoZer & %]
File Edit Yiew Insert Format Table Tools  Help
T & : _ = - 0

A = B S A = R

New Open  Save  Publsh  Browse Unda  Redo Anchor Lk Image  Table  Form CaScades

IEody Text j I(no class) j | oLl | X T

vabewh -] B2 A BT U
~ Site Manager i [ 38751 |
View: IAII files j
L3 o R <] :
I I Products Portfolio Contact Us
e = F test and Grestes sa = Email and Address
QOur Portfolio Solutions™
Qur Products
m Furniture
<body>

Figure 19: A page on KompoZer

Here’s a zoomed in image, we are going to editing the sentence, ‘Welcome to a

world’ to ‘Greetings to a location’.

Solutions™

to he.

born out of the kno
is changing,

: evolution,

Figure 20: Zoomed-in image



Step 5
Using KompoZer, click once on the word that you wish to edit. Notice the blinking

cursor (Figure 20). Now press ‘Backspace’ on the keyboard and change the word

to your desired word. After that, go to File > Save. (Refer to Figure 23) to save

your changes.

Solutions™

MNelcome to a world] where the def
no longer what it used to be.
solutions™ was barn out of the kn

Figure 21: Editing a sentence

Solutions™

.

IS no lonaer what it used to be.
Solutions™ was born out of the knowledge that

work as

we know it, is changing, will change, a

= [1E = BN TET = BT = L=

Sreetings to a location| where th2 definition of ¥

File Edit ‘“iew Insert Format Table Tools  Help
e Chrl+M | g 'f-’ ||- 'Il
d Ry ' 2 '&'u‘ g
£ fmirle D hse Unda Reda Anchor Lirk.
= Open Web Location... Chrl+3Shift+L s o, e
Recent Pages » 3 | LR | (H= el = e e
T Close Chrl-+t == |E ————
I Close All B" U = et
Save As...
i Save And Change Character Encoding
Publish Chrl4+Shift+5
Publish As...
Rewert CLrl+R
Feload Images
Export to Texk. .
Browse Page F5
Page Setup...
Prink... Chrl+P
Exit Chrl+0
|

Figure 23: Saving your changes




KompoZer (Editing the Background Colors)

Now, we are going to edit the color of the background. In this example, the
background is an image, but we will show you how to remove it and add in a

color.

| 200p 1

Products Portfolio Our Clients Contact Us

Latest and Greates Saf = Ernail

Our Portfolio

108px

Our Products

ystem Furniture

|| Marmal [T0] HTML Tags Source | -, Preview

Figure 24:This background in this page is to be edited

Step 1
Locate a ‘Painting’ icon labeled ‘CaScadeS’ at the top panel and click on it.

® Fixx Systems [file:/.../portfolio.html] - KompoZer

File Edit Wiew Inserk Format Table Tools  Help
# i + 1 } e - ¥
. =S M @ Q D @ b ® ww 71 O .| €
Mew pen Save Publish  Browse Unda Redo Anchar Lirk Image Table Farm CaScades
| Bady Text ] | S| njiEs|EaE T E €55 Editor
i i - = == ==
I\n‘arlahlerdth j|.I J‘QYA‘BI u|—=z_——z

Figure 25: Locate this icon, click on it



Step 2

A ‘CSS Stylesheets’ window will be prompted to you. Locate either style.css,
main.css or default.css. These are the files that contain the background
properties. Once located, double click on it.

cssstviesheets x
+ J | General I Texk IBackgru:uund IEh:uru:Iers IEh:ux ILists I.ﬁ.ural I
StyleSheet
Tvpe: texticss
ffi resfstyle.css Disabled: [™ check ko disable styvlesheet (cannot be saved)
[+ cssfextension,cas LJRL: |Fi|e:,|',|',|'C:,|'D|:u:urnents°.-"o2liland°.-"o2IIISettings,l'.ﬁ.dministratur,l'DesktD
Media list: |su:reen

Mumber of rules; 21

o |

Cancel

Figure 26: Look out for style.css / default.css / main.css file




Step 3

A list of words should be expanded as shown in Figure 27. Look for the tag

‘body’ and click on it.

CS5 Stylesheets _

C-D AR

+ 1 | General I Text IBackgru:uund IEh:uru:Iers IEh:ux ILists I.ﬁ.ural I

Sheets and rules

Style rule

css/lighthox. css

=l casfstyle,cas

|:| [u] |:| L'

O]

- #head

- MEY

- may ul

-nay i

~nav i a

-.nav li a:hover
-.nav i a:hover span
-.nav li a span
-right

~fright p
~feright L Full
~ftright . halfleft

Selector;  body

color; #FFFFFF;

font-Family: Arial, sans-serif;
backaround-imaage: url(, . fimg/bg.gif);
background-repeat; repeat;
background-atkachment; fixed;

Figure 27: Click on the ‘body’ tag

Zancel




Step 4

Click on the Background tab, in this case the ‘Image:’ is not empty. (Refer to

Figure 29) Delete the field since we only want to change the background color
and not the background image.

C55 Stylesheets '’

O R

t

!

Sheets and rules

[# css/lightbo, css

=l css)shyle, css
Lk

—navlia

- nay i athower
-.nav li athover span
~.nav li a span

- #right

~#right p

- #right Full

- #right . halfleft

rs

Figure 28: Click on the ‘Background’ tab

W Backaround § Borders I Box I Lists I.ﬁ.ural |
Color; | :l
Opacity: ll _I_PI 1
Image: I..Il'imgll'bg.gif [ Chonse File |
Tile: I hotizontally and wvertically j
[ Image scrolls with the page
Position:

{* Left

" Certer

{~ Right

{* Top
™ Center
" Botkam

5SS Stylesheets .
B | General | Text | Background | Borders I Biox I Lisks I Aural I

[ ) Bl e

L]

sheets and rules

[# casflightbox.css

=l css)skyvle.css

i-body
g ap
-#head
Ay
~nay ul

na i

~nay i a

. navy li aihowver
-.nav li athover span
-.nav li a span

- #right

-gright p

~gright . Full

- #right . halfleft

=

|

Cancel

Colar: | = |

Opacity: LI | M1

Image: |..,|'img,|'bg.giF = Choose File |
Tile: I horizonkally and wertically j

[ Image scrolls with the page

Position:

f+ Left & Center

¢ Right

" Top
i Center
" Botkom

Figure 29: Remove this field if it is filled

o |

Cancel




Step 5

Now, click on the square as shown in Figure 30. A ‘Block Background Color’
window should be prompted. (Refer to Figure 31) Choose your desire color and
press ‘OK’ button. (Refer to Figure 32) Leave the other options as default.
Remember to save your changes once you are satisfied.

£-® = R t

J | General | Text | Background | Borders IEh:ux ILists I.ﬁ.ural I

Sheets and rules

[# css/lightboy, css -

[= cssfstyle.css

|:| L] |:| b

- #wWrap
- #head
- Maw

- naw Ul

naw i

~navlia

- nav li athover
-.nav li aihover span
~.nav li a span
~ftright

~ftright p

~right . Full

-ftright  halfleft

-

| v[1

(= Choaose file |

Color: |

Opacity: il

Image:; | . fimafbg.gif

Tile: I horizontally and wvertically j
[ Image scrolls with the page

Position: @ Left " Center ( Right

{* Top
" Center
" Botkam

Figure 30: Click on this square

o |

Cancel




Block Background Color

HEENT |
| 11 | [
HEEEET | |
HEEEENT |
HEEEN | |

t = Last-picked colar

x

Y
Hue: [o {j Red: [e55 i‘ Hex:  [#FFFFFF
Saturation: ||:| g Green: |255 ﬂ Marne: Iwhite

; : T "
Brightness: |255 ﬂ Elue: |255 :ﬂ I Transparen
Ok I Cancel

Figure 31:This window should popped up
Block Background Color

o
=
I
full
O
o
T
T
=l
(]
=N
f=]
=
L

EEEE |
111 e
EEEE |
HEE |
HEE L
EEEET
SEEED
EEEED |
EEEEET
EEEEE |

N @ 0 e |

9

Hue: [en {j Red: |55 i—j Hes: I#FFFFEIEI
Sakuration: |1|:||:| % Green: |255 i._'.JJ Marne: I*;.-'ellu:uw

{ / T '
Erightness: |255 ﬂ Blue: ||:| :ﬂ I™ Transparen
cancel |

Figure 32: Choose your desired color and press 'OK'

x



108px

300px

Our Clients Contact Us

Home Products Portfolio
o - y = Ermail and Ade

Frortpage Fi y =3

Latest and Gr

Solutions™

Our Portfolio

112 Robinsons
|| Marmal [To] HTML Tags Saurce | “, Preview
Figure 33: Before changing the background
| 203p: ]
= SCRIPT
(]
& =

Home Product: Portfolio Our Clients Contact Us
3 2 s Emzil and Ad

Frortpage Fi Latest and Gr

Figure 34: After changing the background




KompoZer (Undoing the Changes)

If you have made any mistakes or dislike your changes, do not worry. Just make
sure KompoZer is not closed after you have made the changes. Click on Edit >
Undo to undo the changes.

M Welcome to Fixx Systems [file:/.../index.html] - KompoZer

File | Edit Wiew Insert Format Table Tools  Help

Undo |

Mew LB 2 Erowse Undo Redo

Zub Chrl ﬂ| 11
Zopy kel

Paste Chrly *| B/ Q|
Paste Without Formatting

Delete Dl H

H YWelcome ko Fixx Sy
Select All Chel+8

£
.
I

ol

4
L}

Wigws:  Find and Replace... Ctrl+F

Find &gain F3 )
Find Previous Shift+F3
gl
D Zheck Spelling ChelHE -t

Detach From Template
Publishing Site Settings. ..

Figure 35: Undoing Changes

KompoZer (Inserting & Deleting Pictures)

Now we will demonstrate how to change your pictures on your webpages.

Step 1
Open the webpage that you need to insert or delete picture. (Refer to Page 14 if
you are not sure).



Step 2
First, to delete a picture, select it, notice the grid that shows up (Refer to Figure

36), press the ‘Delete’ key on your keyboard to delete.

Products Portfolio Contact Us

mail and Address

Solutions™

Our Products

n Furniture

Figure 36: *NOTE the white grid when you select the picture



Step 3
We will now insert a picture. Go to Insert > Image, a window will pop up as

shown in Figure 38.

® Fixx Systems [file:/.../accessories.html] - KompoZer
File Edit “iew | Insert Format Table Tools Help

e

: — Table...
e Dpel =
Farm... 3

I Body Text Link... Chrl+L

Unda
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Figure 37: Insert > Image
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Figure 23: Click on the folder icon to browse for your image
Make sure your image is in a folder eg, img or image, this is to ensure
manageability and also ensure that the images are linked correctly. Ensure the
‘URL is relative to page location’ checkbox is checked. (Refer to Figure 38)
This helps the website to load the respective images online.




Leave the other options as default and press ‘OK’. Save your changes after you
are satisfied with it.
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Figure 24: Browse for your desired picture
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Figure 25: Picture has been changed successfully



KompoZer (Inserting a Link)

Inserting a link from one page to another can be done in a few simple steps. Now
we will show you how using KompoZer.

Step 1
Open the webpage you want to insert/edit a link. (Refer to Page 14 on how to

open a webpage).

Step 2
Select the word that you want to add a link to.

Figure 26: Select the word

Step 3
With the word selected, right click on it. You should see a list of options as shown

in Figure 42. Choose ‘Remove Links’ if you want to clear a link, else click on
‘Create Link...’
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Figure 27: Right-click on the selected word



Step 4
Now, a ‘Link Properties’ window should be prompted. Type the name of the

page you want the word to link to. Eg, index.html, mypage.html, abc.html. In
addition, you can also type the URL of the website eg, http://www.mypage.com,
http://www.testpage.com/index.html.

Alternately, you can choose to click on the folder icon as shown in Figure 43 and
browse for your webpage that you want to link. Leave all other options as default.
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Figure 28: Type the webpage or browse for it
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Figure 29: Browsing for the webpage
We recommend all the .html files to be in the same location. Eg, index.html’s
location is the same as contact.html ‘s location. This enhances manageability
and enable KompoZer to link it correctly.
Do not forget to save your changes or else the changes will not be made.



Viewing/Checking the Webpages

Very often, we will check the webpages that we have edited. Although KompoZer
is a WYSIWYG (What You See Is What You Get) web page editor, there are
times when they differ when you see them on the webpage.

Step 1
To view the webpages, go to your folder where you save your webpages.

Step 2

Look for index.html and double-click to open it. Check through the webpages for
any mistakes. Eg, those changes you have made whether they have been
modified.
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Figure 30: Open index.html and check for mistakes



CoreFTP (Uploading Your Websites)

Now that you have made all the changes to your satisfaction, you are ready to
upload your website for your visitors.

Step 1
Open Core FTP, connect to the FTP server, refer to Page 10 on how to connect.

Step 2
Once successful, browse the left display panel to the location where your edited

webpages are. Click on the box as shown in Figure 46 and browse to the folder.
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Figure 31: Click the box to browse to location of webpages
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Figure 32: Browsing to the folder



Step 3
In addition, on the right display panel, browse the right display panel into /www/
as shown in Figure 48.
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Figure 33: Right Display Panel to /www/
Step 4
Now, you are prepared to start uploading your edited webpages. After you have
selected the location of your webpages, select all the files except the *..." as
shown in Figure 49 in the left display panel.
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Figure 34: Left Display Panel select all the files except the '...'



Step 5
Locate the “Right Blue Arrow” and click on it to start uploading on to the FTP
server as shown in Figure 50.
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Figure 35: Upload to the FTP server

Step 6
If a window pops up as shown in Figure 51, click “Overwrite All”.
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Figure 36: Click "Overwrite All"



Step 7
The uploading would take place and the status of it would be display at the

bottom of the screen. Time taken of uploading varies on the sizes of your file.

Bytes Size Rate Type Status
—— 0 Upload

Figure 37: Uploading a file

*when transferring, the Status column will be stated as “Xfering”.

When the uploading is successful, the uploaded file can be seen on the window
on the right display panel and the Status would be labeled “Success”.
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Figure 38: Upload completed

Once all the files have been transferred, you can visit your website by going to
www.your_site_name.com as stated when you connect to Core FTP.
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